Cloud Mail - Slow Webmail and Incoming Mail Delivery
Incident Report for SYNAQ
Postmortem

Summary and Impact to Clients

From 09:34am until 19:49pm on the 15th of December 2022, the SYNAQ Cloud Mail platform experienced an incident resulting in slow incoming mail delivery and webmail access for a subset of clients.

More specifically, the affected users experienced intermittent slow access to webmail services, as well as intermittent delays that impacted incoming mail delivery to inboxes.

Root Cause and Solution

The root cause of the incident was a failed write/read cache in one of the redundant RAID array controllers in the Cloud Mail storage network. This resulted in a disk I/O bottleneck affecting the mail store servers attached to that particular RAID array. This bottleneck then also caused mail delivery attempts to queue and as a result mail delivery delays were experienced for some users.

During the incident and before the final solution was implemented, SYNAQ engineers re-balanced certain disks to use alternative I/O access channels as an interim solution to optimise for the degraded performance.

To completely resolve the issue, the faulty cache component was replaced on the Monday following the incident. This returned the affected RAID storage array to optimum performance, negating the need for the interim solution originally put in place.

Remediation Actions

Short Term Actions

SYNAQ will ensure that we keep raid cache components in stock to ensure speedier component swap out (Due End January 2023).

Medium Term Actions

SYNAQ has already begun the process of moving mail store data from current storage technology to next-generation storage, which features much higher I/O capacity and fault tolerance. This project is ongoing and we estimate completion in the next six months.

Posted Jan 11, 2023 - 16:14 CAT

Resolved
Dear Clients,

The SYNAQ Cloud Mail incident has been resolved and the service has returned to optimal functionality.

SYNAQ Technical Team
Posted Dec 15, 2022 - 19:49 CAT
Monitoring
Dear Clients,

Our engineers have implemented a fix for the SYNAQ Cloud Mail platform and are monitoring the mail delivery performance in order to ensure mail backlogs clear as soon as possible.

SYNAQ Technical Team
Posted Dec 15, 2022 - 19:02 CAT
Update
Dear Clients,

Our engineers are still working on the backlog of delayed mail related the ongoing SYNAQ Cloud Mail issue. Mail is still flowing but intermittent delays stills persist. SYNAQ Engineers will be working continuously to ensure optimal Cloud Mail performance in the coming hours

SYNAQ Technical Team
Posted Dec 15, 2022 - 16:26 CAT
Update
Dear Clients,

Our engineers are still working on the backlog of delayed mail related the ongoing SYNAQ Cloud Mail issue. Mail is flowing but intermittent delays stills persist.

SYNAQ Technical Team
Posted Dec 15, 2022 - 15:13 CAT
Update
Dear Clients,

Our engineers are still working on the backlog of delayed mail related the ongoing SYNAQ Cloud Mail issue.

SYNAQ Technical Team
Posted Dec 15, 2022 - 13:38 CAT
Identified
Dear Clients,

Our engineers are still working on the resolution of the SYNAQ Cloud Mail issue. This is being treated as a matter of urgency.

SYNAQ Technical Team
Posted Dec 15, 2022 - 12:15 CAT
Update
Dear Clients,

Our engineers have identified the problem causing the SYNAQ Cloud Mail performance issues and are working on a resolution.

SYNAQ Technical Team
Posted Dec 15, 2022 - 10:37 CAT
Investigating
Dear Clients,

SYNAQ Cloud Mail is currently experiencing a degradation in performance where webmail access (reading emails) may be slow and incoming mail delivery may be delayed - for some users. Engineers are investigating this as a matter of urgency.

SYNAQ Technical Team
Posted Dec 15, 2022 - 09:34 CAT
This incident affected: SYNAQ Cloud Mail.