SYNAQ Cloud Mail - Intermittent SMTP (Outgoing Mail) Sending Failures
Incident Report for SYNAQ
Postmortem

On Thursday, 6 July 2023, 15:25, Cloud Mail experienced intermittent sending failures on the SYNAQ Webmail platform, with outgoing mail. The following concerns were raised:

 

  • Slow response when sending email which contains attachments, and;
  • Emails stuck in Outbox.

 

The resultant impact of the event was that a subset of users who were using Zimbra connector for Outlook were experiencing either a slow response on webmail or ActiveSync and/or  timeout errors when sending emails containing large attachments.

 The root cause of this event was due to a degraded connection state between the load balancer and the mail cluster. This resulted in slow connections on email when trying to login via HTTPS, POP3/S, IMAP/S, SMTP/S, Zimbra connector for Outlook.

 

To resolve this incident, we moved all sessions to the secondary load balancer. This immediately resolved the degraded state and restored the platform to optimal operations.

 Upon investigation of the root cause of the incident,  the SYNAQ team will implement the below remedial actions:

 

·       New Monitoring to be implemented to detect any failed states on the Load-balancer, and;

·       Further streamlining the internal incident management process.

Posted Jul 12, 2023 - 16:57 CAT

Resolved
Dear SYNAQ Client,

Our engineers have both identified and resolved the SYNAQ Cloud Mail incident. The service has returned to optimal functionality and we will continue to monitor the service closely.

Thank you for your patience and understanding on this matter.

Sincerely,
SYNAQ Technical Team
Posted Jul 06, 2023 - 21:45 CAT
Update
Dear SYNAQ Client,

Our engineers are working together with our upstream providers to further investigate the incident. We will continue to provide updates as they become available.

We apologise for the inconvenience caused and would like to assure you that this is being treated as a matter of importance and urgency.

Sincerely,
SYNAQ Technical Team
Posted Jul 06, 2023 - 20:37 CAT
Update
Dear SYNAQ Client,

Our engineers are still investigating as a matter of urgency and will continue to provide updates as they become available.

We apologise again for the inconvenience caused.

Sincerely,
SYNAQ Technical Team
Posted Jul 06, 2023 - 19:37 CAT
Investigating
Dear SYNAQ Client,

We have identified a minor Cloud Mail incident where a subset of clients are experiencing intermittent failures on Sending Outgoing Mails. (Mails stuck in outbox, mail sending failures, cannot upload attachments and send).

Engineers are investigating as a matter of urgency, and we will continue to provide updates as they become available.

We apologise again for the inconvenience caused.

Sincerely,
SYNAQ Technical Team
Posted Jul 06, 2023 - 18:44 CAT
This incident affected: SYNAQ Cloud Mail.